Railway Empire: Crossing the Andes

Operating System:

Windows

Platform:

Steam

£6.31
Adicionar ao carrinho

Railway Empire: Crossing the Andes

Steam account required for game activation and installation
This content requires the base game Railway Empire on Steam in order to play

Feature List:

  • 3 new scenarios covering the early history of railwa...
Railway Empire: Crossing the Andes Railway Empire: Crossing the Andes Railway Empire: Crossing the Andes Railway Empire: Crossing the Andes Railway Empire: Crossing the Andes Railway Empire: Crossing the Andes
Categoria: Estratégia | Publisher: Kalypso Media | Age Limit: 3+ | Developer: Gaming Minds Studios | Release Date: 19/10/2018
Descrição do Jogo

Steam account required for game activation and installation
This content requires the base game Railway Empire on Steam in order to play

Feature List:

  • 3 new scenarios covering the early history of railway pioneers in the Andes.

  • Map expansion: South America region (available in Free Game and Sandbox modes)

  • More than 10 new goods including llama wool and guano, and 34 new cities to discover

  • New engines: Kitson-Meyer (0-8-6-0) and Garratt (2-6-0-0-6-2)

  • Explore the world of Railway Empire in the exclusive night mode


Product Info:

Take on new journeys in the depths of South America in the early 20th century, where a hoard of exotic new resources are ripe for the picking and plans for crossing the Andes by train are drawing attention from investors far and wide. Unforgiving mountains and relentless jungle terrains will make this challenge a tough one for even the most experienced tycoons.

PC System Requirements
MINIMUM:
Requires a 64-bit processor and operating system
OS: Windows 7 SP1 or Windows 8.1 or Windows 10 (64bit versions)
Processor: Intel Core i5 750 @ 2.6 GHz or AMD Phenom II X4 @ 3.2 GHz
Memory: 4 GB RAM
Graphics: nVidia GeForce GTX460 or AMD Radeon HD5870 (2048MB VRAM with Shader Model 5.0)
DirectX: Version 11
Storage: 2 GB available space
Sound Card: DirectX Compatible Sound Card with latest drivers

Linux System Requirements
MINIMUM:
Requires a 64-bit processor and operating system
OS: Ubuntu 16.04.3 LTS + SteamOS (latest)
Processor: Intel Core i5 750 @ 2.6 GHz or AMD Phenom II X4 @ 3.2 GHz
Memory: 4 GB RAM
Graphics: nVidia GeForce GTX460 or AMD Radeon HD5870 (2048MB VRAM with Shader Model 5.0)
Storage: 2 GB available space
Sound Card: DirectX Compatible Sound Card with latest drivers