Cities: Skylines - Content Creator Pack: Modern City Center

Prijs
€4,10
Besturingssysteem
  • Windows
Platform
  • Steam

"simon.ask.simon.to.review"

Cities: Skylines - Content Creator Pack: Modern City Center
Categorie: Simulation Games
Uitgever: Paradox Interactive AB
Leeftijdslimiet: 3+
Ontwikkelaar: Jason “AmiPolizeiFunk” Ditmars
Datum van publicatie: 7-11-2019
Cities: Skylines - Content Creator Pack: Modern City Center
Categorie: Simulation Games
Uitgever: Paradox Interactive AB
Leeftijdslimiet: 3+
Ontwikkelaar: Jason “AmiPolizeiFunk” Ditmars
Datum van publicatie: 7-11-2019

"simon.ask.simon.to.review"

Requirements

Steam account is required for game activation and installation.
This content requires the base game Cities: Skylines on Steam in order to play.

PC System Requirements
MINIMUM:
Requires a 64-bit processor and operating system
OS: Microsoft Windows 7/8/8.1 (64-bit)
Processor: Intel Core 2 Duo, 3.0GHz or AMD Athlon 64 X2 6400+, 3.2GHz
Memory: 4 GB RAM
Graphics: nVIDIA GeForce GTX 260, 512 MB or ATI Radeon HD 5670, 512 MB (Does not support Intel Integrated Graphics Cards)
DirectX: Version 9.0c
Network: Broadband Internet connection
Storage: 4 GB available space

RECOMMENDED:
Requires a 64-bit processor and operating system
OS: Microsoft Windows 7/8 (64-bit)
Processor: Intel Core i5-3470, 3.20GHz or AMD FX-6300, 3.5Ghz
Memory: 6 GB RAM
Graphics: nVIDIA GeForce GTX 660, 2 GB or AMD Radeon HD 7870, 2 GB (Does not support Intel Integrated Graphics Cards)
DirectX: Version 9.0c
Network: Broadband Internet connection
Storage: 4 GB available space

Mac OS X System Requirements
MINIMUM:
Requires a 64-bit processor and operating system
OS: OS X 10.9 (64-bit)
Processor: Intel Core 2 Duo, 3.0GHz
Memory: 4 GB RAM
Graphics: nVIDIA GeForce GTX 260, 512 MB or ATI Radeon HD 5670, 512 MB (Does not support Intel Integrated Graphics Cards)
Network: Broadband Internet connection
Storage: 4 GB available space

RECOMMENDED:
Requires a 64-bit processor and operating system
OS: OS X 10.10 (64-bit)
Processor: Intel Core i5-3470, 3.20GHz
Memory: 6 GB RAM
Graphics: nVIDIA GeForce GTX 660, 2 GB or AMD Radeon HD 7870, 2 GB (Does not support Intel Integrated Graphics Cards)
Network: Broadband Internet connection
Storage: 4 GB available space

Linux System Requirements
MINIMUM:
Requires a 64-bit processor and operating system
OS: Ubuntu 12.04 (64-bit)
Processor: Intel Core 2 Duo, 3.0GHz or AMD Athlon 64 X2 6400+, 3.2GHz
Memory: 4 GB RAM
Graphics: nVIDIA GeForce GTX 260, 512 MB or ATI Radeon HD 5670, 512 MB (Does not support Intel Integrated Graphics Cards)
Network: Broadband Internet connection
Storage: 4 GB available space

RECOMMENDED:
Requires a 64-bit processor and operating system
OS: Ubuntu 14.10 (64-bit)
Processor: Intel Core i5-3470, 3.20GHz or AMD FX-6300, 3.5Ghz
Memory: 6 GB RAM
Graphics: nVIDIA GeForce GTX 660, 2 GB or AMD Radeon HD 7870, 2 GB (Does not support Intel Integrated Graphics Cards)
Network: Broadband Internet connection
Storage: 4 GB available space

Best verkocht